Visual Studio 2008 non supporta .NET 1.0/1.1

Leggo con un certo disappunto dal blog di Irena Kennedy (uno dei miei preferiti, soprattutto per i suoi posts SYSK) che la prossima release di Visual Studio supporterà più versioni del .NET Framework, in modo da avere un unico ambiente di sviluppo installato (questo pensavo io). In realtà le versioni supportate del .NET Framework partono dalla 2.0, quindi 2.0, 3.0, 3.5. Quindi, in pratica, per gestire anche progetti scritti per .NET 1.0/1.1 (e sono veramente tanti in circolazione, soprattutto 1.1) occorrerà avere ancora installate più versioni di Visual Studio.

La cosa mi ha francamente deluso, e sono curioso di leggere (eventuali) feedback tecnici sul perchè di questa scelta apparentemente strana.

One thought on “Visual Studio 2008 non supporta .NET 1.0/1.1

  1. Anche io ci speravo, invece ne aveva gi&#224; parlato Scott Guthrie, spiegandone le motivazioni:<br />&quot;Unfortunately the VS 2008 multi-targeting support only works with .NET 2.0, .NET 3.0 and .NET 3.5 – and not against older versions of the framework. The reason for this is that there were significant CLR engine changes between .NET 1.x and 2.x that make debugging very difficult to support. In the end the costing of the work to support that was so large and impacted so many parts of Visual Studio that we weren’t able to add 1.1 support in this release.&quot;<br />link: weblogs.asp.net/…/…ulti-targeting-support.aspx <br /><br />

Leave a Reply

Your email address will not be published. Required fields are marked *